jlzzjlzz亚洲乱熟在线播放

系統城裝機大師 - 唯一官網:www.farandoo.com!

當前位置:首頁 > 腳本中心 > python > 詳細頁面

Windows環境下Python3.6.8 importError: DLLload failed:找不到指定的模塊

時間:2020-11-02來源:www.farandoo.com作者:電腦系統城

*在起初pip install matplotlib時,主動安裝到當時最新版本(matplotlib==3.3.2),在StackOverflow以及國內眾多帖子中總結以下解決方案

matplotlib3.3.2版本報錯

matplotlib2.2.2版本報錯

matplotlib依賴庫版本不匹配問題(解決問題看下面)

本人在經歷過無數次嘗試matplotlib相關依賴庫 numpy scipy 等安裝卸載
找到所有matplotlib依賴庫正確關系如下圖所示,讓眾生少走些彎路,多留些頭發。
matplotlib官網鏈接如下圖

鏈接: https://matplotlib.org/users/installing.html.

圖片: 在這里插入圖片描述

這些依賴庫最好檢查一下,雖然我們檢查完不解決問題

檢查pip下安裝包(依賴庫)的命令如下

?
1 pip list

卸載安裝包(依賴庫)命令如下

?
1 pip uninstall <依賴庫==版本號>

安裝

?
1 pip install <依賴庫==版本號>

**

最終宇宙無敵究極全網唯一解決方案

報錯原因 :import matplotlib.pyplot as plt 中所有依賴庫版本滿足要求,但還是報錯的原因是在線pip install numpy時因為在線下載numpy庫中缺少DLL,
在以上加州大學非官方庫連接中MKL版本解決了這個問題

下載Numpy+MKL 版本 注意本機Python版本
(說明:下圖中cp36是python3.6.x版本)
注意:下載速度賊雞兒慢,如果有科學上網工具能好一點
**

由克里斯托夫Gohlke,實驗室熒光動力學,加州大學歐文分校
適用于Python擴展程序包的非官方Windows二進制文件。

離線安裝:

?
1 pip install <下載好的文件路徑+文件名>

激動的心顫抖的手,深度學習之路難走呀?。?!哈哈哈終于成了

到此這篇關于Windows環境下Python3.6.8 importError: DLLload failed:找不到指定的模塊的文章就介紹到這了

分享到:

相關信息

系統教程欄目

欄目熱門教程

人氣教程排行

站長推薦

熱門系統下載